public inbox for devel@edk2.groups.io
 help / color / mirror / Atom feed
From: "Laszlo Ersek" <lersek@redhat.com>
To: Ray Ni <ray.ni@intel.com>, devel@edk2.groups.io
Cc: Eric Dong <eric.dong@intel.com>, Rahul Kumar <rahul1.kumar@intel.com>
Subject: Re: [PATCH 1/2] UefiCpuPkg/CpuDxe: Rename variables to follow EDKII coding standard
Date: Tue, 16 Mar 2021 17:30:47 +0100	[thread overview]
Message-ID: <3cecbb33-6838-a0d8-e81d-ed81d33ec4f1@redhat.com> (raw)
In-Reply-To: <20210316033350.2026-2-ray.ni@intel.com>

On 03/16/21 04:33, Ray Ni wrote:
> The change doesn't impact any functionality.
> 
> Signed-off-by: Ray Ni <ray.ni@intel.com>
> Cc: Eric Dong <eric.dong@intel.com>
> Cc: Laszlo Ersek <lersek@redhat.com>
> Cc: Rahul Kumar <rahul1.kumar@intel.com>
> ---
>  UefiCpuPkg/CpuDxe/CpuGdt.c | 27 +++++++++++++--------------
>  1 file changed, 13 insertions(+), 14 deletions(-)
> 
> diff --git a/UefiCpuPkg/CpuDxe/CpuGdt.c b/UefiCpuPkg/CpuDxe/CpuGdt.c
> index a1ab543f2d..322ce87142 100644
> --- a/UefiCpuPkg/CpuDxe/CpuGdt.c
> +++ b/UefiCpuPkg/CpuDxe/CpuGdt.c
> @@ -2,7 +2,7 @@
>    C based implementation of IA32 interrupt handling only
>    requiring a minimal assembly interrupt entry point.
>  
> -  Copyright (c) 2006 - 2015, Intel Corporation. All rights reserved.<BR>
> +  Copyright (c) 2006 - 2021, Intel Corporation. All rights reserved.<BR>
>    SPDX-License-Identifier: BSD-2-Clause-Patent
>  
>  **/
> @@ -13,7 +13,7 @@
>  //
>  // Global descriptor table (GDT) Template
>  //
> -STATIC GDT_ENTRIES GdtTemplate = {
> +STATIC GDT_ENTRIES gGdtTemplate = {
>    //
>    // NULL_SEL
>    //
> @@ -124,32 +124,31 @@ InitGlobalDescriptorTable (
>    VOID
>    )
>  {
> -  GDT_ENTRIES *gdt;
> -  IA32_DESCRIPTOR gdtPtr;
> +  GDT_ENTRIES           *Gdt;
> +  IA32_DESCRIPTOR       Gdtr;
>  
>    //
>    // Allocate Runtime Data for the GDT
>    //
> -  gdt = AllocateRuntimePool (sizeof (GdtTemplate) + 8);
> -  ASSERT (gdt != NULL);
> -  gdt = ALIGN_POINTER (gdt, 8);
> +  Gdt = AllocateRuntimePool (sizeof (gGdtTemplate) + 8);
> +  ASSERT (Gdt != NULL);
> +  Gdt = ALIGN_POINTER (Gdt, 8);
>  
>    //
>    // Initialize all GDT entries
>    //
> -  CopyMem (gdt, &GdtTemplate, sizeof (GdtTemplate));
> +  CopyMem (Gdt, &gGdtTemplate, sizeof (gGdtTemplate));
>  
>    //
>    // Write GDT register
>    //
> -  gdtPtr.Base = (UINT32)(UINTN)(VOID*) gdt;
> -  gdtPtr.Limit = (UINT16) (sizeof (GdtTemplate) - 1);
> -  AsmWriteGdtr (&gdtPtr);
> +  Gdtr.Base  = (UINT32) (UINTN) Gdt;
> +  Gdtr.Limit = (UINT16) (sizeof (gGdtTemplate) - 1);
> +  AsmWriteGdtr (&Gdtr);
>  
>    //
>    // Update selector (segment) registers base on new GDT
>    //
> -  SetCodeSelector ((UINT16)CPU_CODE_SEL);
> -  SetDataSelectors ((UINT16)CPU_DATA_SEL);
> +  SetCodeSelector  ((UINT16) CPU_CODE_SEL);
> +  SetDataSelectors ((UINT16) CPU_DATA_SEL);
>  }
> -
> 

(1) I think "mGdtTemplate" would be a better name than "gGdtTemplate". I
think the "g" prefix is used when an object is identical for all
firmware modules (such as named GUIDs, for example).

(2) I think the last hunk does not belong in this patch -- more
precisely, I *disagree* with the last hunk. Inserting a space in the
middle of a typecast, after the parenthesized typename, is a bad
practice in edk2; it is error prone and suggests that typecasts have low
binding power (when in reality they have almost the strongest binding).

Thanks
Laszlo


  parent reply	other threads:[~2021-03-16 16:30 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-16  3:33 [PATCH 0/2] UefiCpuPkg/CpuDxe: Guarantee GDT is below 4GB Ni, Ray
2021-03-16  3:33 ` [PATCH 1/2] UefiCpuPkg/CpuDxe: Rename variables to follow EDKII coding standard Ni, Ray
2021-03-16 13:58   ` Dong, Eric
2021-03-16 16:30   ` Laszlo Ersek [this message]
2021-03-17  2:47     ` Ni, Ray
2021-03-16  3:33 ` [PATCH 2/2] UefiCpuPkg/CpuDxe: Guarantee GDT is below 4GB Ni, Ray
2021-03-16 13:59   ` Dong, Eric
2021-03-16 16:35   ` Laszlo Ersek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-list from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3cecbb33-6838-a0d8-e81d-ed81d33ec4f1@redhat.com \
    --to=devel@edk2.groups.io \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox